Aug
29

If you are interested in Part 1 of this blog series – click here.

Question 2 of 105

Given the topology and configurations shown in the exhibits. Which devices will receive EIGRP Query packets if R1 loses its route information for the 10.10.10.0/24 prefix?

a) None of the devices

b) R2, R3, R4, R5, R6, R7

c) R2, R3, R6, R7

d) R2, R3, R4, R5

e) R2, R3

Exhibit 1

eigrp

Exhibit 2

R2#show run
Building configuration...

Current configuration : 877 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
no aaa new-model
memory-size iomem 5
ip cef
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
interface FastEthernet0/0
 description Link to R1
 ip address 10.20.20.2 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 description Link to R4
 ip address 10.24.24.2 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 description Link to R5
 ip address 10.25.25.2 255.255.255.0
 duplex auto
 speed auto
!
router eigrp 100
 network 10.0.0.0
 auto-summary
!
ip forward-protocol nd
!
ip http server
no ip http secure-server
!
control-plane
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
!
end

Exhibit 3

R3#show run
Building configuration...

Current configuration : 982 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
no aaa new-model
memory-size iomem 5
ip cef
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
interface FastEthernet0/0
 description Link to R1
 ip address 10.30.30.3 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 description Link to R6
 ip address 10.36.36.3 255.255.255.0
 ip summary-address eigrp 100 10.0.0.0 255.0.0.0 5
 duplex auto
 speed auto
!
interface FastEthernet1/0
 description Link to R7
 ip address 10.37.37.3 255.255.255.0
 ip summary-address eigrp 100 10.0.0.0 255.0.0.0 5
 duplex auto
 speed auto
!
router eigrp 100
 network 10.0.0.0
 no auto-summary
!
ip forward-protocol nd
!
ip http server
no ip http secure-server
!
control-plane
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
!
end

In order to solve this question, we must remember the various options for Query Scoping that were covered in the CCIE R/S Written Class On Demand, and in Petr’s excellent blog post. Remember, summarization, multiple EIGRP ASes, EIGRP Stub, and prefix filtering are all methods of scoping queries.

In this example, we examine R2′s configuration and learn that automatic summarization is left on. But this has no effect whatsoever in this scenario as all devices are numbered in the same major classful network space. On R3, we notice that manual summarization is being accomplished, but notice that will scope the queries at R6 and R7. So any devices BEYOND R6 and R7 will not receive the queries for this subnet, but those devices will indeed receive them.

In summary (no pun intended), we just need to remember here two basic concepts from the course. What are the options to scope queries? How will they impact the query behavior once implemented.

So our answer – option b – R2, R3, R4, R5, R6, and R7 all receive query packets for this network.


You can leave a response, or trackback from your own site.

8 Responses to “CCIE R/S Written Sample Question – Part 2”

 
  1. Abdel says:

    Excelent post,
    Thanks to your post and the one of Petr, I fixed my knowledge about EIGRP query scope.

  2. Marlon says:

    Very good.
    When you stated “…On R3, we notice that manual summarization is being accomplished” you meant that:

    on R3, ‘no auto-summary’ disables summarization, but then you entered ’10.0.0.0′ and that applied a manual summarization.

    Petr article makes more sense to me know.

  3. timaz says:

    i know that when a router receive a query about a network, sees its routing table for that. if it find a summarized network of that queired network, or if it was configured to be stub, thst router sends a reply message and never distribute the query message. but if my thinkings are true, then routers R4, R5, R6, R7 must not receive the query message because both of routers R2 and R3 have the summarized route (10.0.0.0/8) on its tables.

  4. timaz says:

    when auto-summary command was issued on the router, does the router creates a summary (10.0.0.0/8) route to “Null” interface? …. is this route makes the router to reply the Query message and not distribute it?

    • No – the reason a summary scopes the query is because the router does not have an entry for the SPECIFIC subnet in its topology database. It responds to the query and does not forward it as a result.

  5. timaz says:

    as you said, router R2 has the summary route and then must not pass he query to downstream routers. so why routers R4 and R5 receive this queries?

 

Leave a Reply

Categories

CCIE Bloggers